How to use Shockwave

In order to load the Shockwave hotel, you must follow these steps and ensure you have the prequisities required.

Pale Moon

Pale Moon is a necessity to run Shockwave correctly, as it's one of the few browsers that still supports NPAPI plugins correctly.

Since Shockwave is quite old, the 32-bit version of Pale Moon is required, here you can download the Portable or the Full version.

Shockwave 12

You must install the Shockwave 12 MSI first and then proceed to install the Visual Studio 2008 C++ x86 redist.

Download list

Adobe Shockwave 12.3 MSI: Download

Microsoft Visual C++ 2008 Redistributable Package (x86): Download

Also please make sure you do not have a browser open when installing the Shockwave MSI, as you will need to start a fresh Windows installation, since the current installation breaks with a browser open.

Shockwave 11

While Shockwave 11.6 is older than the latest version that is Shockwave 12, the latest version experiences issues with crashing while playing music from the Trax Machine or Jukebox, and also messsages in the instant messenger are always stuck at 12:00.

For these reasons, Shockwave 11 is recommended to install instead since these issues are not present in this version.

You can download the official Shockwave 11.6 installer MSI here.

Why should I use Shockwave?

As of right now there are two clients to play the hotel on, the first is the Shockwave hotel and the second is Flash.

It is highly recommended to play the Shockwave version because it's filled with far more features that cannot be experienced on the Flash client.

The features that Shockwave contains which are not present in the Flash version are listed below.

BattleBall, Diving, Wobble Squabble, Trax Machines, Jukeboxes, American Idol, Tic Tac Toe, Chess, Battleships, Poker and some nostalgic Habbo components such as the hand and the Room-o-Matic.

Prerequisities

The following items are required to use Shockwave are listed below.

If you fail to meet these requirements, you will only be able to play the Flash version.

Requirements

- Microsoft Windows; or

- WINE for Linux and macOS (not supported by Classic staff, as may be unreliable)

- Shockwave (at least 11.6 or higher)

- Pale Moon 32-bit

Stick together!

Classic Habbo is an international Hotel. Being racist and intolerant may lead to your account being banned by a moderator!